#1 2010.01.24 13:28

Gemorroj
Administrator
Откуда: Белоруссия
Зарегистрирован: 2007.11.03
Сообщений: 6545
Карма: 108
Профиль Веб-сайт

Denwer 4

Вобщем, вероятно, многие знают, что на главной странице проекта Denwer вот уже больше года висит сообщение о скором выходе Denwer 4. Но он все никак не выходит, а компоненты Denwer 3 безнадежно устарели и требуют обязательного обновления. Дмитрий Котеров таки решил обновить компоненты Denwer 3 пока не вышел Denwer 4 smile

Дмитрий Кóтеров написал:

Пока Денвер-4 все еще не готов, я решил-таки обновить версии компонентов в Денвере-3.
Теперь в базовом пакете PHP 5.3.1, MySQL 5.1 (и новый phpMyAdmin).
В базовом пакете с Parser - обновлен Parser до самой последней версии.

Также собран и протестирован новый пакет с PostgreSQL 8.4.2 (и да, он теперь не требует внешних dll-файлов).
Обновлен FireBird до 2.1.

Обо всех неполадках прошу писать в форум.

ВНИМАНИЕ: рекомендуемый способ апгрейда - установить новый Денвер в другую папку, убедиться, что все ОК, и перенести туда все свои сайты. Дело в том, что MySQL-сервер переехал в папку /usr/local/mysql-5.1 (раньше был в /usr/local/mysql5), потому что формат баз 5.1 несовместим с форматом баз 5.0. Вообще говоря, конвертация возможна: для этого нужно скопировать папку data из 5.0 в 5.1 и затем выполнить mysql_upgrade.exe (входит в Денвер). Но все это нужно делать вручную.

changelog написал:

Денвер-3 2010-01-24:
Переход к PHP 5.3.1.
Переход к MySQL 5.1.40. ВНИМАНИЕ: MySQL устанавливается в отдельную директорию, /usr/local/mysql-5.1. В случае апгрейда вы должны самостоятельно скопировать туда существующие базы. Переключение версий MySQL производится в файле /denwer/CONFIGURATION.txt.
Переход к phpMyAdmin 3.2.3.
Обновлена библиотека libmysql.dll в parser3.
Добавлена Win32DisableAcceptEx On в httpd.conf для борьбы с криво написанными фаерволами и антивирусами.
ThreadsPerChild уменьшено с 250 до 25 (это экономнее по расходу памяти).
На время работы Денвера строка "::1 localhost" в hosts отключается, т.к. она иногда не позволяет открывать в браузере http://localhost в Vista.

Поскольку на сайте денвера чтобы получить ссылки на компоненты нужно писать свой email и ждать когда придет письмо со ссылкой, решил выложить наиболее необходимые компоненты сюда http://wapinet.ru/files/5536

Неактивен

#2 2011.04.16 17:03

tipsun
Moderator
Зарегистрирован: 2009.10.14
Сообщений: 2279
Карма: 19
Профиль

Re: Denwer 4

Подскажите, пожалуйста, как на denwer ставить доп. библиотеки, поподробней, будьте так любезны smile
Я скачал в архивах:
ImageMagick-6.6.6-Q16-windows.zip
memcache-3.0.6.tgz

Отредактировано tipsun (2011.04.16 17:10)

Неактивен

#3 2011.04.16 17:12

Gemorroj
Administrator
Откуда: Белоруссия
Зарегистрирован: 2007.11.03
Сообщений: 6545
Карма: 108
Профиль Веб-сайт

Re: Denwer 4

dll должны быть собраны под соответствующую версию php. далее просто подключаешь как обычный php модуль.
вообще, качай нужный тебе ZIP архив отсюда http://windows.php.net/download/ с полной заменой стандартного в денвере и настраивай в php.ini что нужно.

Неактивен

#4 2011.04.16 17:14

tipsun
Moderator
Зарегистрирован: 2009.10.14
Сообщений: 2279
Карма: 19
Профиль

Re: Denwer 4

Спс.

Неактивен

#5 2011.04.16 18:48

Nu3oN
Moderator
Откуда: БелгородЭ
Зарегистрирован: 2010.04.28
Сообщений: 863
Карма: 11
Профиль Веб-сайт

Re: Denwer 4

Относительно хорошая новость))


Я буду лучше голоден, но между креслом и рулем и на дороге.

Неактивен

#6 2011.04.17 00:03

Nu3oN
Moderator
Откуда: БелгородЭ
Зарегистрирован: 2010.04.28
Сообщений: 863
Карма: 11
Профиль Веб-сайт

Re: Denwer 4

Никаких кардинальных изменений не увидел, но все же греет душу поставленное))
Вот только пришлось необходимые библиотеки собирать по новой, а так вроде все гуд))
Кстати на phpmyadmin могу дать русификатор если кому то потребуется smile


Я буду лучше голоден, но между креслом и рулем и на дороге.

Неактивен

Дополнительно

forum.wapinet.ru

PunBB Mod v0.6.2
0.009 s